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G2X Software License Agreement 
ACT! For Notes 

 
IMPORTANT. By using the Software governed by this Software License Agreement (“Agreement”), the authorized recipient of such Software 
(herein referred to as “User”) is implicitly accepting this Software License Agreement. If you do not agree with the terms and conditions 
hereof, do not install such Software and return this entire package within 30 days of purchase for a full refund. 

 
Grant of License. G2X hereby grants User a license to install and use the ACT! For Notes application software (which is herein referred to 
the “Software”). User must acquire one license for such Software for each user.  

 
Proprietary Rights, Copyright.  

2.1The Software and all copies thereof are Proprietary to G2X and title thereto remains in G2X. User agrees with G2X that the software 
and related information is owned by G2X.  
2.2 User may (i) make one copy of the Software solely for backup or archival purposes or (ii) transfer the Software to a single hard disk 
provided User keeps the original for backup or archival purposes. User may not copy the Software for any other purposes.  
 

 Restrictions and Obligations. Unless otherwise specifically agreed to or authorized in writing by G2X in each case, User:  
3.1 shall not grant sublicenses or any other rights in or to the Software to others;  
3.2 shall not distribute, transfer, lend or otherwise provide the Software or disclose any information related thereto to any third party 
outside the User’s own organization;  
3.3 shall not copy, compile, reverse engineer or disassemble the Software or attempt to avoid any time limitation therein;  
3.4 shall, at G2X’s request, promptly de-install and discontinue use of the Software and destroy all copies thereof, including all 
compressed files or other files (including documentation) made available to User by G2X hereunder and any copies thereof made by 
User for any purpose;  
3.5 shall comply with U.S. export regulations and any other laws or regulations applicable to the Software; and  
3.6 shall display and not alter or remove G2X’s copyright and other proprietary notices in connection with the Software. Defects. G2X 
agrees to replace any defective software media for a period of 30 days following the delivery of the Software. If a defect occurs during 
the warranty period, a Return Merchandise Authorization Number should be requested from G2X. G2X will only accept returned 
defective products when accompanied by a Return Material Authorization Number.  
 

DISCLAIMER. G2X OR ITS SUPPLIERS WILL NOT BE LIABLE FOR ANY DAMAGES WHATSOEVER, INCLUDING, WITHOUT 
LIMITATION, ANY SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES, ARISING OUT OF THE USE OF OR INABILITY 
TOO USE THE SOFTWARE, EVEN IF G2X HAS BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES IN ADVANCE. IN 
NO EVENT WILL G2X’S LIABILITY IN CONNECTION WITH THE SOFTWARE UNDER THIS AGREEMENT EXCEED THE 
AMOUNTS PAID TO G2X BY USER HEREUNDER. THESE LIMITATIONS APPLY TO ALL CAUSES OF ACTION IN THE 
AGGREGATE, INCLUDING, WITHOUT LIMITATION, BREACH OF CONTACT, BREACH OF WARRANTY, G2X’S NEGLIGENCE, 
STRICT LIABILITY, MISREPRESENTATION AND OTHER TORTS.  

 
Support and Assistance. When requesting technical support or other assistance in connection with the Software governed by this Agreement, 
User must refer to the Registration Number on the box.  

 
Term and Termination.  

7.1 User shall have the right to use the Software unless the Agreement and this license granted herein is sooner terminated  
in accordance with the provisions of this Agreement or in the exercise of rights under applicable law.  
7.2 This Agreement and the license granted herein will automatically terminate in the event of User’s breach of this Agreement.  
7.3 Upon termination of this Agreement for any reason whatsoever, User shall return to G2X the Software and all full or partial copies 
thereof.  
 

 General Provisions.  
8.1 This Agreement shall be binding on User and G2X and their respective successors and assigns. User may not assign its rights or 
delegate performance of its obligations under this Agreement without G2X’s prior consent.  
8.2 This Agreement shall be governed by and interpreted in accordance with the laws of the State of New York.  
8.3 All amendments relating to this Agreement shall be effective only if made in a written document signed on behalf of both G2X and 
User.  
 

 Should you have any questions concerning this Agreement, or if you desire to contact G2X for any reason, please contact:  
 G2X Customer Service 
  20 West 22nd Street, 12 th floor  
 New York, New York 10010  
 Tel: (212) 741-1720 Fax (212) 741-1725  
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Introduction  
 
About this Guide  

This guide describes the fundamental information needed to learn how to set up ACT! For Notes 3.05. Many of 
the features and procedures described may be different from the features in earlier versions of ACT! For Notes. For 
example, Description File information is now stored in the Contacts database in ACT! For Notes 3.05.  

 
What You Need to Know  

The guide’s instructions assume that you have basic understanding of Lotus Notes Release 5 terminology and 
concepts. You should understand views, documents, folders, bookmarks and navigation. In addition, you need to know 
basic administrative tasks, such as signing a database.  

 
The figures shown in this guide were made using the U.S. version of ACT! For Notes and Microsoft 

Windows 98; therefore, some figures shown in this guide may be slightly different from the ones shown on 
your screen if your software configuration is different.  

 
Conventions Used in This Guide  

Conventions used in this guide are:  
⌦TIP: This symbol indicates a tip or a helpful note. 

   Alert: This symbol displays when an action may cause loss of information in your ACT! For Notes 
Database.  

This guide has these action button and menu command conventions:  
Menu commands appear in caps, as shown from this example: From the Action menu or button, choose 
CONTACT>CREATE NEW CONTACT.  

• 

• 
 

To indicate that you need to choose a command from a pull down menu or submenu, the > sign is used, as 
shown in this example: From the Action menu or button, choose COMPANY>CREATE NEW COMPANY.  
 

How to Use this Guide  
 
To help you find what you need when using this guide, the following list describes each chapter: 

• Chapter 1: Installing ACT! For Notes describes the system requirements and installation procedures. 
• Chapter 2: Setting Up ACT! For Notes shows you how to prepare your ACT! For Notes database for your 

users. 
• Chapter 3: Converting and Exporting Data shows you how to import and export data with ACT! for 

Windows. 
• Chapter 4: Managing Your Data describes the use of the Other action button. 
• Chapter 5: Customizing ACT! For Notes describes ways to modify your ACT! For Notes database. 
• Chapter 6: Setting Up PDA Synchronization describes how to enable ACT! For Notes for PDA 

synchronization. 
• Chapter 7: Accessing ACT! For Notes from a Web Browser show you how to set up and use ACT! For 

Notes for web access. 
• Chapter 8: Keeping the Database Consistent shows you how to maintain the data in ACT! For Notes.  
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Chapter 1: Installing ACT! For Notes  
This chapter tells you:  
 

The system requirements for installing and using ACT! For Notes • 
• 
• 

• 

• 
• 
• 

• 

How to install ACT! For Notes on a server 
How to Upgrade ACT! For Notes 

 
System Requirements 
The following items describe the requirements for installing and using ACT! For Notes:  
 

Server Information:  
 

Domino Supported Platforms:  
• Windows NT4.0/Intel 
• Windows NT4.0/Alpha 
• IBM AIX 4.3.1 
• HP-UX 11.0 
• Solaris/SPARC 2.6 
• Solaris/Intel 2.6 
• OS/2 Warp Server 4 
• IBM AS/400 V4R2 
• IBM S/390 V2R6 

 
Memory Requirements:  
• IBM AIX 4.3.1: Minimum 64MB, 128MB or more recommended. 
• Microsoft Windows NT4.0 (Intel or Alpha): Minimum 48MB, 96MB or more recommended. 
• Sun Solaris/SPARC and Intel Edition: Minimum 64MB, 128MB or more recommended. 
• IBM AS/400 V4R2 or later: Minimum 64MB, 128MB or more recommended. 
• IBM S/390 V2R6 (with UNIX Services Active): Minimum 128MB (64 MB for OS/390 and 64MB for 

Domino for S/390), 256MB or more recommended. 
 

Disk Space:  
Minimum 750MB, 1G or more recommended.  

 
Protocols:  

TCP/IP on all platforms. 
X.PC supported on all platforms, except IBM OS/400 and IBM OS/390. 
SPX, SPXII, NetBIOS/NetBEUI, VINES, X.25, SNA, and ISDN supported or selected platforms. 

 
Lotus Notes Software  

Domino release 5.0.1 or later server software. 
 

Workstation Requirements:  
 

Operating System (one of the following)  
• Microsoft Windows 95/98 
• Microsoft Windows NT 
• Microsoft Windows 2000 
• Microsoft Windows XP Enterprise edition 
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Memory/Disk Space Requirements:  
• 32MB RAM, 12MB disk space 
 
Lotus Notes Software  
• Lotus Notes release 5.0.1 or later (stand alone, remote dialup, or networked connection). 

 
Optional  
• Microsoft Windows Supported Mouse 
• Hayes or 100 percent compatible modem 
• Printer 

 

To Enable Web Access to ACT! For Notes Databases  
 

• Lotus Notes/Domino release 5.0.1 or later Server, mail enabled 
• A server that is set up to run the HTTP server task 

 
 

Installing ACT! For Notes on a Server  
 

To install ACT! For Notes, you need to complete two tasks:  
 

• Install ACT! For Notes directly on the Server; or, install it locally and make a replica on the Server. 
 

• Add bookmarks for the following databases: ACT! For Notes Contacts and ACT! For Notes Help. 
 

Note: The following procedure assumes you are using Microsoft Windows NT server software.  
 

 
Installing ACT!  for Notes on a Domino Server:  

 
1. Start Windows, and then start Lotus Notes.  
 
2. Insert the ACT! For Notes CD into the appropriate drive.  
 
3. From the Lotus Notes File menu, choose DATABASE>OPEN.  The Open Database dialog box displays.  
 
4. Click Browse Button. A dialog box displays, asking you to choose a Notes database or template file.  Select 

Notes Database.  
 
5. Select the CD drive. The files on the CD appear in the dialog box. 
 
6. Select the setup file in the dialog box. For example, to install the United States version, select US.NSF.  
 
7. Click Select.  The name of the setup database displays in the Open Database dialog box.  
 
8. Click Open in the Open Database dialog box.  The ACT! For Notes installation screen displays. 
 
9. Click the Install ACT! For Notes button. A dialog box displays, displaying information about your computer 

and the version of Lotus Notes that you are running.  
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10. If Notes 5.0.1 or higher is detected, click OK to proceed. If you are running an earlier version of Notes, the 
dialog box will inform you that ACT! For Notes 4.1 cannot be used with your version of Notes. The 
Installation and Setup screen displays.  

 

 
 

11. Deselect any database file you do not want to install. You can enter a different directory location if you do not 
want to install the database files in the default directory, for instance, C:\NOTES\DATA.  

**If you choose to place these files in a folder, then the folder must already exist.  The install process does not create 
folders. 
 
Caution: If you receive the following Execution Security Alert message, click Trust Signer.  This indicates that you 
must sign the all of these .ntf and .nsf files once they are on the server with an ID that is trusted to run agents and send 
mail on that server. 
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If you want to install the files in a directory other than the default directory, create the new directory before 
starting the installation process. If you do use a different directory, the list of templates does not display the 
template files when you create the new ACT! For Notes databases from the templates. You will need to copy 
the templates to the Notes\Data directory.  For more information, see Chapter 2, “Setting Up ACT! For 
Notes”.  

Caution: If you are upgrading ACT! For Notes, the template file names are the same, and you could 
overwrite the existing templates. It is recommended to backup those templates to another directory or rename 
them before continuing the installation process.  

12. Click the Start Install button.  
 

If you did not deselect any files, the installer places the following databases and templates into the directory 
you specified.  

ACTDB.NTF, The ACT! For Notes Contact Database Template • 
• 
• 
• 
• 
• 

ACTHELP.NSF, ACT! For Notes Help Database 
DEMODB.NSF, The Demo Contact Database 
ACTMAIL.NTF, The ACT! For Notes Database Mail Template (Full Calendar Integration) 
MAIL.NTF, The ACT! For Notes Mail Database Standard Template (Low Calendar Integration) 
AFNCPAGE.CVP, a fax cover page for use with the ACT! For Notes Fax Options 

 
A message displays when the installation is complete.  

13. Click OK, and then Exit Install.  
 
 

To Add Database Bookmarks to a Bookmark Folder:  
 

1. From the File menu, choose DATABASE>OPEN. The Open Database dialog box displays.  
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2. Choose the server directory where you installed the ACT! For Notes databases.  
 

Note: If you install the files anywhere except Notes default Data directory, you need to click the Browse 
button to locate the ACT! For Notes files, before you complete the next step.   

3. In the File Name text box, type the name of the ACT! For Notes Demo Database (DEMODB.NSF) and click 
Add Bookmark. 

 
4. Select the name of the Bookmark folder for which you want to store the Bookmark.  

 
5. Repeat the previous step to add an icon for ACTHELP.NSF, the ACT! For Notes Help database.  

 
6. Click Done.  

 
 

Upgrading ACT! For Notes  
 

If you have a contact database created with an earlier version of ACT! For Notes, you need to replace the design 
of the contact database, and if you are using calendar integration, you need to replace the design of the Notes mail file 
to update the database designs.  

 
To Upgrade from ACT! For Notes 3.05 and earlier:  

 
Use the installed ACTDB.NTF file on ACT! For Notes CD-ROM to replace the design of the corresponding 
Contact database. 

• 

 
• Alert: Perform the next steps ONLY if your previous version of ACT! for Notes was lower than 3.0: 

� Update the company and activity documents in the contact database by using two special agents.  In the 
Admin Navigator, choose the Preferences view.  Use the Actions drop down menu to run both ‘Update 
Activities to version 1.5 or higher’ and ‘Update Company Addresses to version 2.0’.  The agents update 
the activity and contact/company documents for use with the AFN 4.1 features in the contact database. 

 
� The preferences document will also need to be updated to version 4.1.  In the preferences view, choose 

the action ‘Update to version 4.1’. 
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• 

• 

� Since there is no Description file in version 4.1, you will want to copy and paste all User Fields, Pop-Up 
Entries, Other Application documents and Correspondence Headers into the appropriate view in the 
Admin Navigator of AFN 4.1. 
 

Users who wish to use calendar integration must update the design of their Notes mail file, using the 
ACTMAIL.NTF or MAIL.NTF template.  For more information, see Chapter 2. 

 
Have users who use a local replica replicate with the server and automatically receive updated design and 
data after replacing the database design and updating the activity documents on the server.   You will want to 
have them remove the Description and Reports database files from their workspace if the previous version of 
ACT! for Notes was below 3.0, as these databases are no longer needed for AFN 4.1.  For more information 
about how to replace a database’s design, see Lotus Notes documentation. 

 
 

To upgrade the company and activity documents in the contact database (if previously running ACT! for 
Notes below 3.0):  

 
1. Open your ACT! For Notes Contact database.  
 
2. Click on the Admin Navigator and choose the Preferences view. OR  Select 

VIEW>ADMINISTRATION>PREFERENCES. 
 
3. From the Actions menu, select ACTION>UPDATE ACTIVITIES TO VERSION 1.5 OR HIGHER.  

 
4. A dialog box displays, asking you to confirm.  Click Yes to run the upgrade agent. The agent runs in the 

background.  
 

5. From the Actions menu, select ACTIONS > UPDATE COMPANY ADDRESSES TO VERSION 2.0 
 
6. A dialog box displays, asking you to confirm.  Click Yes to run the upgrade agent. The agent runs in the 

background.  
 

 
To upgrade the preferences document in the contact database (if previously running ACT! for Notes below 
3.0):  
 
1. Open your ACT! For Notes Contact database.  

 
2. Click on the Admin Navigator and choose the Preferences view. OR  Select 

VIEW>ADMINISTRATION>PREFERENCES. 
 

3. Choose the action button, UPDATE TO VERSION 4.1.  
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Chapter 2: Setting Up ACT! For Notes  
 
This chapter tells you how to set up ACT! For Notes by completing the following tasks:  

 
Creating databases from templates • 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

 
Set up access to the database 

 
Set up Preferences 

 
Check the Public Name & Address Book 

 
Document Level Security 

 
Create User documents 

 
Customize ACT! For Notes 

 
Create a full text index 

 
Create local replicas 

 
View replication or save conflicts 

 
⌦TIP: It is recommended that you complete these tasks in the order listed. 

Note: In the following procedures, when you are asked to save the document, either choose Save from the File 
Menu to save the document before closing it or save it when you choose Close from the File menu.  

 

Creating Databases from Templates  
 

When you install ACT! For Notes, it installs templates you use to create your own set of ACT! For Notes 
databases. The following templates are installed in the directory you specified:  

 
ACTDB.NTF, the contact database template. 

 
ACTMAIL.NTF, a customized mail file template that allows the Notes mail file to interact with ACT! For 
Notes for High Level Calendar Integration. 

 
MAIL.NTF, a standard Notes 5 mail file with only additional design elements for use with Low Level 
calendar integration. 

 
**  All templates must reside in the default notes directory in order to use them to create databases. 
 
After you create your databases from templates, complete the remaining procedures in this chapter to set up and 

modify the databases for your needs.  
 
Before creating databases from your templates, you must sign the templates with a trusted ID using the Notes 

server administrator tool.  The ID should be able to run agents and route mail on the designated server. 
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To sign the templates:  
 

1. Start Domino Administrator.  
 

2. Click on the Administration task button in the task bar.  
 

3. Make sure you are using a trusted user ID to sign a template or database.  
 

4. Select the server that stores the databases or templates that you want to sign.  
 

5. On the Files tab, select the databases or templates that you want to sign.  
 

6. Choose Tools - Database - Sign.  
 

7. Select All design documents to sign every design element.  
 

8. Click OK.  
 

A dialog box shows the number of databases processed and the number of errors that occurred (if any). You can 
see details about the errors in the log file (LOG.NSF) and use database analysis to analyze the errors.  

 

To create a contact databases from the template: 
 

1. From the File menu, choose DATABASE>NEW. The New Database dialog box displays.  
 

 
 
 

2. From the Server drop-down list, choose the server where you want to place the new database. 
 
3. In the Title text box, type a title for the new database. The title is automatically used to create a filename 

(with a .NSF extension) in the File Name field.  
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4. From the list of templates, choose the ACT! For Notes contacts template (ACTDB.NTF). The list of 
templates is drawn from the default Notes data directory on local or on a specified server.  

 
Note: When you choose a template from the list, the file name displays next to the About button. (e.g. ACTDB.NTF). 
The list of templates is drawn from the default Notes data directory on either the Local directory or from a specified 
server. Contact your Administrator if you cannot find the template. 

 

 
5. Check the box marked Create full text index for searching and click OK. This allows you to perform a full 

text search through the fields of all documents.  
 

After the process is complete, an icon for the new database displays on the workspace.  When you create the 
contacts database, the About Database document displays.  

 

Setting Up Access to the Database  
 

To use an ACT! For Notes database, you need to set up the Access Control List (ACL) for each database. The 
ACL lists all users, groups of users, and servers that can access a database, and specifies the level of access for each.  

 
The level of security set in the ACL interacts with the document-level security set inside ACT! For Notes to 

determine what individual users can access..  
 
To help you quickly set up and manage ACLs, you can create an ACL for groups of users with the same access 

rights. Database managers are given Manager access. Other users are given Editor or Author access with or without 
the ability to delete documents, depending on your circumstances. For more information about the various access 
levels, see the Lotus Notes documentation.  

 
The following entries must be present in the ACL to ensure proper security functionality: 
 

LocalDomainServers Group containing all trusted 
servers in the current domain 

• Manager access 
• Delete rights 
• [AFN Admin] role 

OtherDomainServers Group containing servers from 
other domains 

• No Access 

anonymous Default web user • No Access 
• Unspecified 

[AFN Admin] role Access to Administrative 
functionality 

 

 
Rules to go by: 
 
Preferences Document:  Manager access and the [AFN Admin] role 
User Field Labels and PopUp Entries (Edit and Create):  Editor access and the [AFN Admin] role 
General Users:  Author (recommended) or Editor access, no special roles,  
 
Alert: All users must have rights to create Personal Views/Folders on the server 
 
To set up the Access Control List:  

 
1. On the workspace, select ACT! For Notes contact database.  
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2. From the File menu, choose DATABASE>ACCESS CONTROL. The Access Control List dialog box 

displays. 
 

 
  
 

3. Click the Add Button.  The Add User dialog box displays. 
 

4. Click on the ‘blue person’ icon to choose names groups and/or server from the public Name & Address book. 
Using the public Name & Address book helps avoid typing errors. The new entry name displays in the 
People, Servers, Groups drop-down list.  

 
5. From the Access drop down list, select the security access such as Manager, Author or Reader. Users should 

be given Editor or Author access. Only database managers should have Manager access. In order for users to 
create and edit the Preferences document or Administration documents or run Administrative Agents, the 
role, [AFN Admin] must be checked.  

 
6. (Optional)  Select or deselect the appropriate “create” and “delete” options  

 
7. Click on the Advanced button and select the “Enforce a consistent Access Control List across all replicas of 

this database” option.  
 
** If you are planning on accessing ACT! For Notes via the web, set the default access to No Access and add a 

user called ‘Anonymous’ with No Access and no user type. 
 

8. When finished, click OK.  
 

Repeat this procedure for the Help database.  
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• 

• 

• 

• 

• 

• 

• 

• 

The [AFN Admin] Role  
 

The Access Control List of the contacts database contains one role, [AFN Admin]. This role restricts access to 
certain elements in the database.  
 

Access Restrictions : 
 

To create User Field Labels, Pop-Ups, Other Application documents, and Correspondence Header, you must 
have Editor access or higher and be in the [AFN Admin] role. 

 
To edit User Field Labels, Pop-Ups, Other Application documents, and Correspondence Header, you must 
have Editor or Designer access and be in the [AFN Admin] role, or have Manager access.  

 
To run any of the Admin Tools agents or set up/edit the Preferences document, you must have Manager 
access and be in the [AFN Admin] role.  

 

Setting up Preferences  
 

Proper execution of several functionalities requires values from the Preferences document, therefore it is 
recommended that Preferences is set immediately.  When you set up ACT! For Notes preferences, you enter the 
following information:  

 
The path name and file name of the Help database.  After you enter the file name information and save the 
Preferences document, the ACT! for Note contact database will be linked to the Help database. 

 
No matter where you are running ACT! For Notes , you must fill in the Server File Name and Local File 
Name fields in the Preferences document.   

 
(Optional)  Group Security. Identify Notes groups that will have access to the database that you would like to 
use in Document Level Security. 

 
(Optional)  Name Separators. You can change the name prefixes and suffixes, such as Mr. And Ms., that the 
contact documents use to separate first and last names for views. 

 
Inheritance.  You can specify which fields to inherit when users create contact and company documents based 
on the current document. 
 

• Pipeline. Enable Pipeline integration.  Pipeline is a Sales Forecasting database that can integrate with ACT! 
For Notes, also sold by G2X. 

 
• NAB Integration.  Specify how contacts should synchronize with the Name and Address Book (NAB) for 

PDA synchronization. 
 
 

To set up a Preferences document:  
 

1. Open the ACT! For Notes contact database.  
 

2. Click on the Admin Navigator and choose the Preferences view.  OR  From the View menu, choose 
ADMINISTRATION > PREFERENCES. If you are opening a new database, choose ADMINISTRATION > 
PREFERENCES from the Create menu to create a Preferences document.  
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3. Open the Preference document in edit mode. The Preference document displays.  
 

 
  
 

4. In the Server File Name field and the Local File Name field, type the file name of the ACT! For Notes Help 
Database, ACTHELP.NSF.  

 
If you did not install the ACT! For Notes database files in your Lotus Notes default data directory, type the 
path name relative to the default Notes data directory to specify the location of the help files.  

If the help database is installed in the default Notes directory, C:\NOTES\DATA, type the name such as 
ACTHELP.NSF. If you are using the help database on the server and you installed the description database 
in F: \ACTNOTES\DATA, type F:\ACTNOTES\DATA\ACTHELP.NSF.  

If you are using ACT! For Notes on a local workstation and copied the help database to the workstation, 
you must specify its location on that workstation. For example, if ACTHELP.NSF is in 
C:\ACTNOTES\DATA, type C:\ACTNOTES\DATA\ ACTHELP.NSF. **All users should create their 
local replicas in the same place as there is only one Preferences document per database. 

5. When you type in the database name in Step 4, ACT! For Notes reads the database title from the file and fills 
in the title field for you.  

 
6. (Optional)  If you plan to use Notes (Public NAB) groups to give additional read and/or write access to 

specific documents within the database, on the group security tab list the group names. It is best to select the 
names from the Public Address book: Click the pop-up icon next to the group name field to access it. Search 
for the group that you wish to add, highlight it and click the Add button. Click Ok when completed.  

 
7. (Optional)  Change or add entries to the Name separators section of the document.  

 
**Within the contact document, there is only one field for the Contact’s name.  You should place the whole name 
is this field eg.  Mr. John Smith PhD.  The name separators will be used to help define the contact’s first and last 
name.  Define any other common name separators here.  Punctuation, spelling and spacing must match exactly. 
 
Note: When the Contact name itself contains a combination of characters that could be interpreted as a prefix or a 
suffix (eg. De in Adeline), the automatic Fist and Last name calculation will not be accurate.  Users must use the 
Override First/Last name button in the Contact document to correct the name. 

 
8. (Optional)  You can select which fields to inherit when creating contacts and companies based on a current 

document.  
 

9. (Optional)  You can opt to configure with G2X Sales Pipeline.  
 

10. (Optional)  If you plan to synchronize data with a NAB, you can select your NAB Integration preferences.  
 

11. Save the document by choosing FILE>SAVE from the menu.  
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Additional Setup Procedures for Web Access  
 

If you wish database users to be able to access the ACT! For Notes database from a Web browser, there are 
additional setup requirements:  

 
• The ACT! For Notes Database must be running on a Lotus Domino 5.0.1 server or higher. 
 

The server must run the HTTP task. 
 

Ensure the database is properly signed. 
 

Internet passwords are set up for users who will be accessing ACT! For Notes via the web. 
 

The ACT! For Notes Contact database must be in your default Notes directory or in a path relative to it. 
 

The URL for your database will be h  address of your server]/[path to database relative to default ttp://[IP
Notes directory]/.  **The trailing slash is a MUST! 

 
Users’ Internet login name and password are specified in their person document in the Public Address Book.  • 

• 

• 

• 

 
For maximum Internet security, make the Default in your ACL No Access, and create an entry called 
anonymous with No Access (Unspecified user type).  

 
In Database properties, the option Web Access: Use JavaScript when Generating Pages must be de-
selected 

 
In database properties, the launch option for the browser must be set to Open Designated Page - main 

  
 • 
 
Consult the Lotus Domino documentation for further information.  

 

 

 16

http://[ip/


ACT! For Notes 4.1                  Administrator’s Guide 
 
 
 
 

• 

• 

• 

• 

• 

• 

• 

Creating User Documents in AFN 
 

You will need to create a user document for each individual who will use ACT! For Notes. A user document 
provides information and personal settings for each person who has access to the database. For example, the document 
lists the person’s home and business address, telephone and fax numbers, and e-mail information. You can create a 
user document in one of two ways.  

 
Create document a single user document at a time. 

 
Import multiple people from the Name & Address Book at once. 

 
After you create a user document, you can view, edit or delete it.  

You must use a hierarchical naming scheme in Notes to create User documents in ACT! For Notes. This 
hierarchical name is stored on the user document in a hidden field called Canonical Name, and is critical to 
scheduling, security, and personal views.  

This section tells you how to:  

Create User documents one at a time  
 
Import multiple people from the Name & Address Book 

 
Set up User Preferences on User Documents 
 
View and edit user documents 
 
Delete user documents 

 
To create user documents one at a time:  

 
1. Open the ACT! For Notes contact database.  

 
2. Click on the Admin Navigator, the default view is the User List. 
 
3. From the Create Menu, choose USER. The name dialog box displays.  
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4. From the drop-down list, choose the address book that contains the name of the person for whom you want to 
create a user document. The list of people in the book displays.  

 
Alert:  You must have access to the Public Name & Address Book when creating users to ensure that proper 
canonical name is recorded. 

 
5. Select a person’s name and click OK.  

 
The new user document displays in edit mode The name of the person that you selected displays in the User 
field.  The organization part of the hierarchical name displays in the Company field.  

 

 
  
 

6. Enter the basic information about the user in the Company, Title, Phone, Address, City, State and Zip Code 
fields.  

 
Click the Groups pop-up icon to add this user to an ACT! For Notes group.   

 
To import people from Name & Address Book:  

 
1. Open the ACT! For Notes contact database.  
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2. Click OTHER>IMPORT FROM NAME & ADDRESS BOOK.  
 

The Import from Name & Address Dialog box displays.  
 

 
 
3. Select the User radio button.  

 
4. Select the Name & Address Book you wish to use.  You cannot import Users from a Local address book since 

it does not store canonical names. 
 

5. Click Add to view a list of people in the Name & Address Book.  
 

6. Select the names of the people for whom you want to create a user documents and click OK.  
 

A list of names selected displays in the dialog box  
 

7. When completed, click OK. The User documents are automatically created and can be viewed in the User list.  
 
“User Preferences” configures the following options for this user in the database.  
 
1.  The Create Note when fields Change options for a Contact Form or Company Form determine whether ACT! 

For Notes creates a note containing the new information when one of these fields changes.  
 

For example, if the Last Results option is selected for the contact form and the user makes a change to that 
field, ACT! For Notes stores the new information from this field in a note.  

**This is only true for contact and company documents in which the user is the document manager.   

Check the boxes for fields for which you want these notes created for this user.  

2. The Calendar Integration fields cause ACT! For Notes to interact with Notes mail file such that the ACT! For 
Notes calendar and the mail file calendar remain consistent and ACT! For Notes invitations are sent to the 
user’s mail file when activities are scheduled for them.  
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You must have upgraded the design of the user’s mail file database and selected the correct Calendar Profile 
options for this to work completely.  See “Enabling Calendar Integration” in this guide or Chapter 8 in the 
User’s Guide for a more complete discussion of Calendar Integration.  

Check both boxes in this area if you want to enable Calendar Integration for this user.  

3. NAB Integration (Optional).   This feature allows you to select the Personal NAB for PDA synchronization of 
contact documents. 

 
4. (Optional)  The Word Processor (32-bit) feature allows you to select the type of word processor used for 

creating Word Processor Documents. The selected Word Processor will automatically launch when a Word 
Processor Document is created.  

 
ACT! For Notes works with the following (32 bit) word processors: Lotus Word Pro, Microsoft Word 

and Corel Word Perfect.  
 

 
5. The Security Settings feature allows you to set Security Preferences for the following features:  

 
Set Default Security Status on documents the user creates.  

• Determine if the document is a public or private document. 
 
• Select the document manager(s). 

 
• Determine which user(s) have read/write access to the document. 

 
 

6. The Signature feature allows you to attach a piece of text, an image or an HTML file to append copyright 
message or personal matter when using e-mail within AFN. 

 
7. Save the document.  

 
** You must set up the User Preferences information on each User Document individually. 
 

To view, edit or delete an existing user document:  
 

1. Open the ACT! For Notes contact database.  
 

2. From the View menu, choose ADMINISTRATION>USER LIST.  
 

A list displays in the view pane.  

3. View, edit or delete as you would any standard Notes document.  
 
 

Enabling Calendar Integration  
 

• No Calendar Integration – No communication between ACT! For Notes and your personal mail file calendar. 
No action is necessary. 

 
• Low Level Calendar Integration – This is a one-way exchange of information, which synchronizes the ACT! 

For Notes calendar with your mail file calendar. Also, ACT! For Notes invitations (notifications) are sent to your mail 
file when activities are scheduled for you by another user. 
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• 

• 

1. In the Calendar Integration section of the User’s User Document, select ‘Synchronize Calendar with My 
Mail File’ and ‘E-Mail Invitations to My Mail File’. 

 
2. Replace the User’s mail file database design with the ACT! For Notes Standard Mail Template (Mail.ntf) 
 
•  High Level Calendar Integration – The ACT! For Notes calendar and your personal calendar communicate 

and data is exchanged and synchronized between the databases. A change in either database will be reflected on both 
databases.    

 
 
1. In the Calendar Integration section of the User’s User Document, select ‘Synchronize Calendar with My 

Mail File’ and ‘E-Mail Invitations to My Mail File’. 
 
2. Replace the User’s mail file database design with the ACT! For Notes Mail Template (Actmail.ntf) 

 
3. Change the Mail File Calendar setting for each user.  Choose the Tools action button, then select 

Preferences.  Find the ACT! For Notes tab.  Select ‘Send ACT! For Notes Activity Changes to ACT! For 
Notes’ and ‘Synchronize Calendar Entries with ACT! For Notes’.  Then direct your mail file to the ACT! 
For Notes database on the server as well as on local (if necessary). 

 

Customizing Field Labels, Pop-Ups, and Other Features  
 

This section tells you how to customize the following features:  
 

User Field labels and pop-ups 
 

Letter, Fax and Email templates 
 

Agents 
 

Links to other Lotus Notes databases 
 

Note: You must be in an Editor and have the [AFN Admin] role, to perform the following procedures.  

Customizing Field Labels and Pop-Ups   
 

You can customize the user field labels that appear on the Company, Contact, Activity and User Documents. 
Customizing allows you to use labels that are familiar to your users and applicable to the tasks they perform.  

 
You can also create pop-ups to provide a list of commonly used values for fields on the Company, Contact, 

Activity, Notes and User documents. When you use ACT! For Notes, you access a pop-up list by clicking a pop-up 
icon that is located next to the field.  

 
This section tells you how to:  
 
Create new user field labels 

 
Edit user field labels 

 
Create new pop-up lists 

 
Edit pop-up lists 
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Available User Field Labels 
 
20 Company User Field Labels 
20 Contact User Field Labels 
20 User User Field Labels 
4 Activity User Field Labels 
 
** ACT! For Notes will not allow you to create more user field labels than are available on the form. 
 
Note:  You must be an Editor and have the [AFN Admin] role to perform the following procedures. 
 
To create new user field labels:  

 
1. Open the ACT! For Notes Contact database.  

 
2. Click on the Admin Navigator and choose the User Field Label view. 
 
3. From the Create menu, choose ADMINISTRATION>USER FIELD LABEL.  

 
A blank new User Field label document displays.  

 

 
 

4. Click the Form pop-up icon. The Select Keywords dialog box displays.  
 

5. Select the form, such as Contact, in which you want to create a user field label and click OK.  
 
The form name displays in the Form field 

  
In the Original Label field, click the pop-up icon and select the user field you want to define from the dialog box. For 
example, select User 1.  (The Original Label will always be User 1 – 4 or User 1 – 20 depending on the form.) 
  
In the New Label field, type the new label. The new label will appear in the selected type of form in the User Fields 
area. 
   
Click the Exit button to save this new label 

 
Repeat Steps 3 through 7 to create additional user field labels. Type User 2, User 3 and so on in the Original Label 
field for each additional user label.  
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To edit user field labels:  
 
1. Open the ACT! For Notes Contact database.  

 
2. From the View menu, choose ADMINISTRATION>USER FIELD LABELS or click User Field Labels in the 

Admin navigation pane. A list of original labels for the Company, Contact, User and Activity forms displays.  
 

3. To change a field label, select and open it in Edit Mode by clicking on the Red Pencil Icon  .  
 

4. In the New Label text box, type the new label name. 
 
** No other field should be changed on the form except perhaps the description/other Information field.  ALSO, 

existing data will not reflect the changes until the values are manually changed. 
 

5. Click the Exit button.  
 
The Customized field label displays in the User Field Labels view.  
 
6. Repeat Steps 3 through 5 for each field that you would like to change.  
 
Fields that can have an associated Pop Up Entry: 

 
Form Field 
Activity Type 
 Regarding* 
 *Based on a value in the Type field 
  
Company City 
 State 
 Country 
 Industry 
 ID/Status 
 Groups 
 Billing City 
 Billing State 
 Billing Country 
 Shipping City 
 Shipping State 
 Shipping Country 
  
Contact City 
 State 
 Country 
 ID/Status 
 Last Results 
 Groups 
 Alt. City 
 Alt. State 
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 Alt. Country 
  
Note Type 
 Regarding* 
 *Based on a value in the Type field 
  
User City 
 State 
 Country 
 ID/Status 
 Last Results 
 Groups 
 Alt. City 
 Alt. State 
 Alt. Country 

 
 
To create new Pop-up lists:  

 
1. Open the ACT! For Notes Contact database.  

 
2. Click on the Admin Navigator and choose the Pop Up Entry view. 
 
3. From the Create menu, choose ADMINISTRATION>POP-UP ENTRY.  
 
A blank Pop-up document displays.  

 

 
 

4. Click the Form pop-up icon. The Select Keywords dialog box displays listing the Contact,  
Company, User, Activity, and Notes forms.  

 
5. Select the form for which you want to create a pop-up list and click OK.  

 
The form name displays in the Form field in the Pop-up for the document.  
 
6. In the Field Label/Type field, click on the pop up icon and choose from the list of available fields.  For 

example, if you want to create a pop-up list of States, choose State in the field.  
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Note: You can create a Pop-up list for any field that has a pop-up icon next to it in an ACT! For Notes document.  

 
7. In the Pop-up Entry field, type an entry for the pop-up list. Press the Enter key and type the next item.  

 
8. After adding all the items to the list, click the Exit button to save the document.  

 
9. Repeat Steps 2 through 7 to add another pop-up list.  

 
Note: To create a pop-up list for the Regarding field in the Activity or Note form, select the type of activity in the 

Field Label/Type field. (The Regarding pop-up is based on the type of activity.) Type the list of items for the 
Regarding field in the Pop-up Entry field.  

 
To edit pop-up lists:  

 
1. Open the ACT! For Notes Contact database.  

 
2. In the Admin Navigation pane, click Pop-ups.  

 
The pop-up lists appear in the view pane.  

 
3. Select the pop-up list that you want to change and open it in Edit mode.  

 
Note: Be sure to select the list itself not the header.  
 

The Pop-up document displays.  
 
4. In the pop-up Entry field, change the item(s) or add new ones. Press the Enter key after you add an item to the 

list.  
 

5. After making all desired changes, click the Exit button to save the document.  
 
Adding a Logo to a Fax Form  
 

For a professional look, you can add your company’s logo to your fax messages. To add a logo, you need to create 
a correspondence header document in the Contact database. The fax logo will appear on all outgoing fax messages sent 
from ACT! For Notes.   A header can be either an image or text and you can create more multiple Correspondence 
Header documents to use as fax stationary.  

 
To add a logo to the fax form:  

 
1. Open the ACT! For Notes Contact database.  

 
2. Click on the Admin Navigator and choose the Correspondence Header view. 
 
3. From the Create menu, choose ADMINISTRATION>CORRESPONDENCE HEADER. 

 
4. The Correspondence Header document displays.  

 
5. Enter “Fax” in the Form field. If you click the pop-up, Fax is the only choice.  
 
6. In the Header/Logo field, choose Import from the File menu and select the graphic to import. Click  
OK.  
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Note: You can also insert the logo by moving the graphic from the Clipboard and pasting it in the field, or by 
typing in text. 

 
7. Save the document and close it.  

 
8. Open the contact database and create a new fax document (select the header you want to display) to check 

that it displays.  
 
 
Linking ACT! For Notes to Other Lotus Notes Databases  
 

You can access other Lotus Notes databases by linking the databases to AFN.  
 
To create a link to another database:  

 
1. Open the Contact database.  

 
2. Click on the Admin Navigator, and choose the Other Applications view. 
 
3. From the Create menu, choose ADMINISTRATION>OTHER APPLICATION.  

 
The Other database document displays.  
 
4. Type the other database information, such as database name, title and server location.  

 
5. If you want to create a form in the other database, type the name of the form as it displays in the design of the 

other database.  
6. If you want to open a specific view, type the name of the view as it displays in the design of the other 

database.  
 

7. In the Purpose field, type the text that you want to appear as a command to go to the link.  
 

8. Save the document.  
 

Once the document is saved, you will be able to go directly from your ACT! For Notes database to the 
specified view or form by selecting Application on the Action Bar, then, choosing Other Application.  

 

Creating a Full Text Index  
 

Full text index is a feature of Lotus Notes. The index allows you to perform a full text search that looks at all data 
stored in the fields of all the documents in a view. When you create a new database, you may want to create a full text 
index for it. After you create the index once for a database on a server, Lotus Notes automatically updates it.  

  
You can set the frequency of the server update in the Properties for Database dialog box. Click the Full Text tab 

and choose frequency from the Update Frequency drop-down list. 
 
Note: Local databases are not automatically updated.  
Alert:  You must be database manager in the ACL to create the full text index. 
 
To create a full text index for a database:  

 
1. Open the ACT! For Notes database.  
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• 

• 

 
2. From the File menu, choose DATABASE>PROPERTIES.  

 
3. Click the Full Text tab (magnifying glass icon).  

 
4. Click Create Index.  

 
The Full Text Create Index dialog box displays.  
 
5. Select the index settings and index breaks you want to use and click OK.  

 
The indexing begins. The amount of time requires to generate an index varies, depending on the options 

selected and the amount of text in the database. A message displays telling you when the index is complete.  
 

 

Creating Local Replicas  
 

To create a full replica 
 

You can create a local replica of a database that contains all of the database’s documents and design.  
 
1. Open the ACT! For Notes database.  

 
2. From the File menu, choose REPLICATION>NEW REPLICA.  

 
3. Fill in the fields in the New Replica dialog. For Server, select Local. Enter a file name for the replica.  

For Create, click immediately.  
 

4. (Optional) Do one or both of the following:  
 

To encrypt the replica so that it can be opened only with your user ID, click Encryption, select “Locally 
encrypt this database,” and click OK.  
To create an index so you can perform full text searches on the replica, select “Create full text index for 
searching.” 
 

5. Click OK.  
 

Note: Notes adds a bookmark entry and a database entry to the Replicator for each local replica you create. You 
can use the Replicator page to update your replicas.  

 
To create a partial replica  

 
1. You can create a local replica of a database that contains selected documents, shortened documents, and/or 

selected parts of the database’s design. You can also specify a maximum size for a local replica.  
 

2. Open the ACT! For Notes database.  
 

3. From the File menu, choose REPLICATION>NEW REPLICA.   
 

4. Fill in the fields in the New Replica dialog. For Server, select Local. Enter a file name for the replica.  
For Create, click Immediately.  
 
5. (Optional) To limit the size of the replica, do one or both of the following:  
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• 

 
To specify the maximum size for the replica, click Size Limit, select a number of gigabytes, and 
click OK. 
To specify selective replication settings click Replication Settings, specify the settings you want, and 
click OK. 

 
For more information, refer the Lotus Notes Documentation.  
 
6. (Optional) Do one or both of the following:  

 
To encrypt the replica so that it can be opened only with your user ID, click Encryption, select 
“Locally encrypt this database,” and click OK.  
To create an index so you can perform full text searches on the replica, select “ Create full text index 
for searching.” 

 
7. Click OK.  

 
Note: Notes adds an entry for each local replica you create to the Replicator workspace page. You can use the 
Replicator page to update your replicas.  

 

Viewing Replication or Save Conflicts  
 

ACT! For Notes provides a Replication Conflict view so that you or other users can quickly see any replication or 
save conflicts after replicating a database. The Replication Conflict View displays replication and save conflicts in 
both contact and company documents.  

 
You need to resolve any conflicts manually and then remove replication or save conflict documents. Clicking the 

Remove Documents from View button does not resolve the conflicts. It removes the document from this view. You 
should remove the documents only after the conflicts have been resolved. 

 
To view replication or save conflicts:  

 
1. Open the ACT! For Notes Contact Database.  

 
2. Click on the Admin Navigator and choose the Replication Conflicts view.  OR  From the View menu, choose 

ADMINISTRATION>REPLICATION CONFLICTS.  
 
ACT! For Notes displays the replication or save conflicts view.  

 

To remove document(s) from the Replication Conflict view:  
 

1. From the View menu, choose ADMINISTRATION>REPLICATION CONFLICTS.  
 

ACT! For Notes displays the replication or save conflict view.  
 
2. Both the Original document and the conflict will display in this view.  You need to compare the documents, 

make any necessary edits to the original document and then delete the conflict. 
 
3. Once you have deleted the conflicts, select the document(s) that you want to remove.  

 
4. Click the Remove Documents from View button on the Action Bar.  (This does not resolve the conflict, it 

simply removes them from this view.)   
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Chapter 3: Converting and Exporting Data  
 

This chapter tells you how to:  
 

• Convert ACT! For Windows 2.x, 3.x, 4.x or 2000 contact, activity, notes and history database 
information and append it to an ACT! For Notes database. 

 
• Export ACT! For Notes information into an ACT! for Windows 2.x database. 

 
Alert: When you convert or import data, you append information to the information already in the database. 
Therefore, you must not convert the same data more than once or you will have duplicate information in the 
database. 

 
The conversion procedures are different for ACT! for Windows 2.x, 3.x and 4.x databases. Choose the conversion 
procedure that corresponds with your version.  

 

Convert Act! For Windows 2.X to ACT! For Notes 3.x 
 

When converting an ACT! For Windows database to an ACT! For Notes database it is a two-part process: 
 
Note:  Beginning the Data Conversion ensure that ACT! For Windows and ACT! For Notes are installed on your 
Local Machine. 
 

Section 1 
            

1. Open the ACT! For Windows database that you wish to convert  
 
2. Make sure you write down the file name and path of the Database for use later in the conversion process. 

 
 
3. Select the following: FILE > ADMINISTRATION > DATABASE MAINTENANCE. 

 
             Note: Please read the ACT! For Windows explanations carefully before choosing the type of maintenance and 
proceeding. 

 
                    4. Once you have chosen the type of maintenance, click on the Reindex button. 

 
Section 2 

¾ Note:  Before beginning the conversion process open the blank ACT! For Notes database and create User 
Documents for all people who will be using the database. 

 
1. Open the ACT! For Notes database select the following from the drop down menu: CREATE > DATA 

CONVERSION > 2.  CONVERT FROM ACT! 2. X. 
 

¾ Note:  Database does not have to be blank. This conversion will simply add to the number of 
documents that already exist in your ACT! For Notes database. 
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Once selected the following dialog box will display: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. In the ‘Directory containing the ACT! database you wish to convert’ field, you will type the file location. For this 
example this ACT! For Windows database is located in C:\actwin\database 
 

¾ Note:  Please do not type the file name into the first field, just the file location. 
 
3. In the ‘File name of the ACT! Database you wish to convert’ field, enter just the name of the file. This file is located 
in the same string that you had typed in the “Directory containing” field in the previous instructions. 

 
¾ Note: Be sure when entering the file name just enter it as you see it. Under no circumstances will you need 

to enter in a file extension. For this example the ACT! For Windows database file name is DEMO. 
 

4. Click on the Convert Database button. This will begin the process of Data Conversion; a message will display 
informing you that the converted data will be appended to the ACT! For Notes Database, when prompted click OK the 
progression bar will display showing the conversion rate. 

 
5. A message will display telling you that the Data Conversion is complete, click ok. Choose the Exit ACT! Data 
Conversion button.  A message will display asking you to Set Manager and Access for new document, click OK and 
you will be in your new ACT! For Notes database. 

 
¾ Note: You may need to click Refresh or F9 to see your new documents. 
 

Section 3 
 
Once Data Conversion is complete you must make sure that the data that you have just converted is consistent. You 
must first Set Manager and Access and then Synchronize Data. 
 
 

¾ Note: Please reference Chapter 5 for instructions on how to ‘Set Manager and Access’ and ‘Synchronize 
Data’. 

 
ACT! For Windows contains only Contact documents, while ACT! For Notes contains both Contact and 

Company Documents.  When you convert data into ACT! For Notes from ACT! For Windows, you will need to create 
company documents. 
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Select one Contact from each Company. 
Click on the Company action button then select “Create Multiple Company Documents”. 
 
Note:  This feature will allow you to create Company Documents from the Contact List. The information that is 

inherited comes from the Contact.  The information that can inherit can be viewed/edited from the preferences 
document under the “Inheritance” tab. 

 
The final step would be to select all contact documents, select the Contact action button, and select Link Contact 

to Company.  You will be presented with two options, select ‘Link Contacts to Companies of the Same Name’. 
 

 
Converting an ACT! for Windows 3.x, 4.x or 2000 Database  

 
Before you convert your ACT! for Windows 3.x (which must be version 3.06 or higher), 4.x or 2000 database, 
perform the synchronization and re-indexing tasks described under “ Converting an ACT! for Windows 2.x 
Database”.  
  
If your ACT! for Windows 3.x, 4.x or 2000 database contains more than 10,000 contacts, you will need to split it 
into smaller databases after compressing and re-indexing.  
 
To convert an ACT! for Windows 3.x, 4.x or 2000 database:  

 
1. Create a local replica of the ACT! For Notes server database which you want append the converted data.  

 
2. From the Create menu, choose DATA CONVERSION>CONVERT FROM ACT! 3.X AND 4.X.  

 
The ACT! Data Conversion document displays.  

 
 
 

 
 
 

3. There are several requirements for conversion from ACT! for Windows 3.x, 4.x or 2000:  
 

• The ACT! for Windows and ACT! For Notes databases must be on the same local hard disk. 
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• You must have installed the conversion utility.  By default, it installs when you install ACT! For Notes. If 
you did not install the utility, click the Install Converter button on the Data Conversion document. You will 
need your ACT! For Notes installation CD.  If Convert.exe already exists, overwrite it, so that you have the 
most current version of the converter. 

 
4. Click the launch Data Converter button once the above requirements are met.  
 
The converter dialog box displays: 
 

 
 
5.  The default name for the ACT! for Windows 3.x, 4.x or 2000 database file will be in the ‘Select ACT! file to  
Convert” area. Change this if it is incorrect or click Browse to search your hard drive for the database.  You 
should always choose the file with the DBF file extension. 
 
6.  Click “ Set Notes Database” to specify the currently open ACT! For Notes database:  

 
 

 
 
 

5. Click “Convert Data” to start conversion.  
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6. If your ACT! for Windows database is in separate pieces, repeat steps 5-7 until complete.  

 
7. Click “Exit ACT! Data Conversion” to close the conversion application once the conversion is complete. 

 
8. Refresh your views in ACT! For Notes to view imported data.  
 

Alert: After you convert an ACT! for Windows 3.x, 4.x or 2000 database, the manager field needs to be updated 
so that security works properly.  You can use the Set Manager and Access feature in the Other action button to 
select a new manager for the selected contact documents.  

 
ACT! For Windows contains only Contact documents, while ACT! For Notes contains both Contact and 
Company Documents.  When you convert data into ACT! For Notes from ACT! For Windows, you will need to 
create company documents.  Groups are imported into the Categories field of the ACT! for Notes Contact 
documents. 
 
Select one Contact from each Company. 
Click on the Company action button then select “Create Multiple Company Documents”.  
 
Note:  This feature will allow you to create Company Documents from the Contact List. The information that is 
inherited comes from the Contact.  The information that can inherit can be viewed/edited from the preferences 
document under the “Inheritance” tab.  This feature does not check for duplicates, so if several Contacts belong to 
the same company, that many company records will be created.  You will need to remove the extras. 
 
The final step would be to select all contact documents, select the Contact action button, and select Link Contact 
to Company.  You will be presented with two options, select ‘Link Contacts to Companies of the Same Name’. 
 

 
Exporting ACT! For Notes to an ACT! For Windows 2.X Database 
 
Open the ACT! For Notes database select the following from the drop down menu: Create\ Data Conversion\ 4.  
Export to ACT! 2.X 
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Once selected the following page will display: 
By left-clicking and holding the mouse on Click here for Instructions, the instructions will display. 
   

 
 
 

1. In the first field, type the directory that contains the database that you want to export.  
 

2. In the second field, type the file name of the database to which you want to export. Do not include the file 
extension.  

 
3. Click the Export Database button. A progress gauge displays indicating the progress of the export.  

 
4. Click the Exit ACT! Data Export button after the export is completed to re-index the new data.  
 

Field Maps  
 

The following table provides a field map between the contact documents in ACT! For Notes and ACT! for 
Windows 3.x, 4.x or 2000. The activity, history, and notes documents map directly from field to field, using similar 
names and formats.  

 
The values in the tables are actual field names and may not match the associated field label in the database. An 

N/A in the table indicates that the field is not converted or is not required in the ACT! For Notes database. In addition, 
some ACT! for Windows 3.x, 4.x or 2000 fields are joined to create a new field in ACT! For Notes.  

 
When you convert any ACT! for Windows 3.x, 4.x or 2000 contact, activity, history and notes data that 

information becomes public in ACT! For Notes.  
 
Contact Field Mapping  

ACT! for Windows 3.0.6 or later Fields ACT! For Notes Fields 
CF_Name Contact 
CF_Company Company 
CF_Create Timestamp CreateDate 
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CF_EditTimestamp EditDate 
CF_Creator Manager 
CF_Creator Creator 
CF_Address1 Address1 
CF_Address2 Address2 
CF_Address3 Address3 
CF_City City 
CF_State State 
CF_Zip Zip 
CF_Country Country 
CF_IDStatus Status 
Parsed from CF_Phone CountryCode 
CF_Phone Phone 
CF_Fax Fax 
CF_HomePhone HomePhone 
CF_MobilePhone MobilePhone 
CF_Pager PagerPhone 
CF_Salutation Salutation 
CF_Title Title 
CF_Assistant Assistant 
CF_LastResults LastResults 
CF_ReferredBy ReferredBy 
CF_User1 User1 
CF_User2 User2 
CF_User3 User3 
CF_User4 User4 
CF_User5 User5 
CF_User6 User6 
CF_User7 User7 
CF_User8 User8 
CF_User9 User9 
CF_User10 User10 
CF_User11 User11 
CF_User12 User12 
CF_User13 User13 
CF_User14 User14 
CF_User15 User15 
CF_AltAddress1 AltAddress1 
CF_AltAddress2 AltAddress2 
CF_AltCity AltCity 
CF_AltState AltState 
CF_AltZip AltZip 
CF_AltCountry AltCountry 
CF_AltPhone OtherPhone 
CF_Name2 Asst2 
CF_Phone2 Asst2Phone 
CF_FirstName FirstName 
CF_LastName LastName 
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CF_Ext Ext 
CF_AsstPhone AssistPhone 
CVF_EmailAddress Email 
GF_Name (Group Names) Categories 

 
 

Activity Field Mapping 
ACT! for Windows 3.0.6 or later Fields ACT! For Notes Fields 
AF_CreateTimestamp CreateDate 
AF_EditTimestamp EditDate 
AF_Type Categories 
AF_Priority Priority 
AF_Regarding Regarding 
AF_StartTime Date 
AF_StartTime Time 
AF_StartTime CalendarDateTime 
AF_StartTime StartDateTime 
AF_StartTime + AF_Duration EndDateTime 
calculated from AF_Duration Duration 
calculated from AF_Duration DurationType 
AF_LeadTime LeadTime 
Recurring Activity Information Text 

 
 

Notes-History Field Mapping 
ACT! for Windows 3.0.6 or later Fields ACT! For Notes Fields 
NHF_CreateTimestamp CreateDate 
NHF_EditTimestamp EditDate 
NHF_Type Categories 
NHF_Text Regarding 
NHF_UserTime Date 
NHF_UserTime StartDateTime (cleared activities) 
NHF_RecordedTime Time (cleared activities) 
NHF_Attachment Attachments 

  
 

NOTE: ACT! for Windows stores attachments as pointers to a file. If the file exists in the stored path, the 
attachment is created as an embedded object in the note, otherwise only the path name is stored.  
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Chapter 4: Managing Your Data 
 

 

Go To My User Document 
 
User documents are required for every person who will be using ACT! For Notes in your organization. Normally, 
your ACT! For Notes Administrator creates these documents in advance.    
 
To view your own User Document, click on the Other action button and select Go To My User Document.   
 

 
 

Your User Document displays. 
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Edit the document by pressing the  red pencil button in the tool bar.  
 
Your name appears in the User field. The organization part of the hierarchical name appears in the Company field. 
 
Enter the basic information about you.  Title, Phone, Address, City, State, and Zip Code fields, if the fields are not 
already filled in. 
 
 “User preferences” configures the following options for you in the database. 
 

• 

• 

• 

• 

• 

Create Note when fields Change options for a Contact Form or Company Form determine whether ACT! For 
Notes creates a note containing the new information when you change one of these fields. 

 
For example, if the Last Results option is selected for the contact form and you make a change to that field, 
ACT! For Notes stores the new information from this field in a note. This is only true for contact and company 
documents in which the user is the document manager.  

 
Check the boxes for the fields on which you want these notes created. 

 
The Calendar Integration fields cause ACT! For Notes to interact with your Lotus Notes mail file and calendars.  

Such that the ACT! For Notes calendar and the mail file calendar remain consistent and ACT! For Notes 
invitations are sent to your mail file when activities are scheduled for you. 

 
Your administrator must have upgraded the design of your mail file database and selected the correct Calendar 
Profile options for this to work completely.  
Check both boxes in this area if you want to enable Calendar Integration, if they are not already selected. 
 

The NAB Integration feature allows you to enable Synchronization between ACT! For Notes and your Personal 
Name and Address book (NAB), so that you may choose to synchronize your personal NAB with your PDA 
device. 

First, identify the filename and path of your personal name and address book, either by typing in the value or 
by clicking ‘Choose NAB’ to browse for it. 

Second, determine whether you are using a standard Lotus Notes designed address book or if any 
customizations have been made to the address book you are using. 

 
With the ‘AFN changes Overwrites NAB changes’ selected, HotSync manager will distinguish changes between 
ACT! For Notes and your NAB and give ACT! For Notes the priority to overwrite the Data in the NAB. 
 
With the ‘NAB changes overwrites AFN changes’ selected, HotSync manager will distinguish changes between 
ACT! For Notes and your NAB and give your NAB the priority to overwrite the Data in ACT! For Notes. 
 
With the ‘Don’t synchronize changes’ selected, HotSync manager will NOT distinguish any changes between 
ACT! For Notes and your NAB and the Data will remain intact in both the NAB and ACT! For Notes. 

 
 
The Word Processor (32-bit) feature allows you to select the type of word processor used for creating Word 

Processor Documents. The selected Word Processor will automatically launch when a Word Processor 
Document is created. 

• 

• 

 
ACT! For Notes work with the following (32 bit) word processors: Lotus Word Pro, Microsoft Word and Corel 
Word Perfect. 

 
The Security Settings feature allows you to set  default security status on documents the user creates.   

 

 38



ACT! For Notes 4.1                  Administrator’s Guide 
 
 
 
 

• 

• 

• 

• 

• 

Determine if the document is a public or private document. 
 

Select the document manager.   
 

Determine which users have read/write access to a document.  
 

Select the group for which the user should belong. These user groups are used for scheduling activities, as 
well as document security. 

 
Note:  See Appendix A for additional information regarding document security. 
 
The Signature feature allows you to attach a piece of text, an image, or an HTML file to append copyright 

message or personal matter when using e-mail. 
 
Save the document by clicking the Exit action button. 

 
 

Synchronize Data 
 
Anytime any of the information for a Contact or Company document changes you have the option to also change 

all of the response documents.  Select the main document (Contact or Company) click the twisty down and select the 
response documents (notes, activities, etc.) under it.  Choose the Other action button, and select Synchronize Data.  
Any inherited information that you changed on the main document (Contact or Company) will now change in the 
response documents (anything under the twisty). 
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Print Form 
 
This feature will simply allow you to print the whole form,(Main Documents and Response Documents) it will 

open up all the tabs so that you may print the whole form and not just what’s in the view.   
 

Replace or Clear Field Values 
 
This feature also found under the Other action button allows you to change information on multiple documents for 

the same fields.  You would select the documents that you would like to change and then click the Other action button 
and choose to Replace Field Values or Clear Field Values.   

 

 
 
If you select Replace Field Values you will see the following form appear.  You will need to fill in the fields that 

you want to change for all of your documents (be careful because this will change the fields on all the selected 
documents). 

 

 40



ACT! For Notes 4.1                  Administrator’s Guide 
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When you select OK, it will prompt you to make sure that you do want to update all the currently selected 
documents. 

  

 
 
If you select Clear Field Values in the dialog box. 
 

 
 
You will see this form, so that you may select the fields you would like to clear on the documents you selected. 
 

 
 
 
When you choose Continue it will prompt you to make sure you have the appropriate fields selected to clear. 
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Click OK and the fields you selected will be blank.  
 

Import from Name & Address Book 
 
Import from Name and Address Book allows you to bring in Contacts from your personal Name and Address 
Book.  To do this, click the Other action button and choose Import from Name & Address Book.  You will see the 
following dialog box.  Choose the Add button, to open your personal address book in order to select those 
contacts to add to ACT! For Notes. 
 
Alert: Although you can bring Users and Groups from the Name and Address Book, you can only do so using a 
Public name and address book, since those names are later used for security purposes.  If you try to import a user 
or a group from the local address book, you will get an error message and the import will be automatically reset to 
Contact. 
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You will see the Contact(s) names that you selected.  If they are correct, click OK.   
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You will now see these Contact name(s) appear in the Contact List view.  
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Export Utility 
 
Export Utility provides a tool to export ACT! For Notes information into a text or document file.   
 
Note:  This action will not remove information from ACT! For Notes, it will simply copy information out. 
 
Select the Contacts that you would like specific information Exported, click the Other action button and choose 
Export Utility.   

 
You will see this dialog box with three tabs.  The first tab is the Settings, this allows you to setup your new 
document by: 
 
Define the file name and path 
Determine the file type, and  
Choose to include Column Headers or not.  
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The next tab Common Fields allows you to select the fields that you would like in your export, you do this by 
choosing the field in the left margin. 
 

 
 
The User Fields tab allows you to select the User Fields that you would like to include in your export.   
 

      
 
Choose OK when you are finished with your selections. 
 
A file will automatically be created based on the information you provided on the Settings tab.  You now need to 
go open it in the application you selected. 
 
Note:  You can easily open a text file in any spreadsheet application. 
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Reporting  
 

Reporting provides a tool to query ACT! For Notes information and export it into a spreadsheet file.  It has a 
Query Builder dialog to make it easier to create/update a search query and stores the query in ACT! For Notes.  
All documents meeting the search criteria are exported along with the column headers. 
 
Select the Other action button, and choose Reporting. The Reporting dialog box appears. 
 

  
 
Select Main or Response documents to export to your spreadsheet file. 
 
Check the type of documents that you want to export (Contact, User or Company). 
 
Select the fields that you want to export. 
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Building the Query.  After selecting the fields you would like included in your report, select the Query Builder 
tab. 
  

 
 
We are interested in searching our database to determine which Contacts in the New York State area have a title 
of President.  We will build a query by inputting this information. 
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Operators Legend: 
= equal contains Text is part of a field  
<= Less than or equal to does not contain Text is not part of a field  
>= Greater than or equal to ( ) Isolate condition 
!= Not equal to AND Multiple conditions must be true 
< Less than OR Only one of multiple conditions must be true 
> Greater than NOT Negative condition 

 
Follow these steps to build this Query.   
 
Select  the field value from the left box.  In our case “State”  then choose the “Paste field”  button.   
In the bottom center, select the appropriate operator.  In our case, select contains or =. 
In the bottom right, type the field value.  In our case, type “NY” then select the “Paste value” button.   
 
Note:  This accomplishes the first portion of our search; all contacts in the state of New York. 
 
In the operator section, select AND because we want the documents to meet both of these criteria. 
Select the “Title” field from the left and choose to “Paste field”. 
Select operator contains or = President.    
 
Note:  Contains operator will allow the search to pick up Vice President as well.  = operator will only allow for 
the exact value of President.  
 
On the bottom right, type the value “President” (this search is not case specific) then choose to “Paste value”. 
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If you would like to save this query, click the Save Query button.  A dialog box appears requesting that you name 
your query.  We will name our query NY Presidents.   
 

 
 
Load Query will allow you to pull up a previously saved query. 
 
Remove Query will allow you to delete a previously saved query. 
 
Back to the Export tab. 
 

 
 
Click on the Run Query button.  A spreadsheet file will launch with the results of your query. 
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Chapter 5: Customizing ACT! For Notes  
 

As an ACT! For Notes administrator, you can customize your Lotus Notes databases for a workgroup’s needs. 
Additionally, if you are an application or database developer, you can change a database’s design by viewing and 
modifying selected pieces of the source or database code. Like many Lotus Notes database applications,  ACT! 
For Notes is customizable in similar ways.  You must purchase the source code to perform customizations of this 
sort. 
 
To customize ACT! For Notes, you should be familiar with Lotus Notes application development. For more 
information about Lotus Notes application development, see the Lotus Notes’ Application Developer’s Guide.  
 
This chapter explains which features you can and cannot customize in an ACT! For Notes database. To learn more 
about customizing an ACT! For Notes database, contact your G2X sales representative for more information.  
 
Note: G2X cannot offer Technical Support on how to customize ACT! For Notes, nor on any ACT! For Notes 
features which have been customized in any way.  
 
Alert: If you have purchased a version of ACT! for Notes without the source code, it is strongly recommended 
that you refrain from any type of customizations.  Although the code is not visible, it is nevertheless there and any 
additions will automatically invalidate original functionality. 
 

About Customizing ACT! For Notes  
 

As you install the software, ACT! For Notes is ready to use. However, if you choose, you can modify your ACT! 
For Notes database. You can change field labels, add fields on forms, change existing form layouts, and customize 
many other ACT! For Notes features.  
 
All of these changes are possible using Lotus Domino Designer.  
 
Caution: An application developer should exercise caution when customizing ACT! For Notes. Every form has 
hidden fields, in the user interface, integrated into the products operation. Some fields have values computed 
based on the values contained in other fields. You cannot tell which fields are computed fields on a form because 
the formulas are hidden. Therefore, if you remove those fields, you can damage the functionality of the form.  
 
When customizing ACT! For Notes’ forms, you should try not to remove the default fields. Some fields, such as 
user fields, can be removed without damaging the form. However, because you may not be sure which fields can 
be removed without affecting the functionality of the form, you may not want to delete any fields on the form. 
Instead of deleting fields from a form, you can hide the fields by using the text properties of the form.  
 
Views have even stricter restrictions than forms. Because @DbLookup, @DbColumn, and @PickList functions 
use views and extract data based on the position of the column in a view, you should not insert or delete columns 
in existing views. You may add views without adversely affecting existing programming; however, views are 
physical structures and adding new views can add to the database size, which could affect performance.  
As you become familiar with ACT! For Notes, you may want to extend its functionality or modify it for your 
needs. The next section explains which features you can customize.  
 

Ways to Customize ACT! For Notes  
 

In ACT! For Notes, you can change or customize many database features. The following list describes the ACT! 
For Notes features that you can customize and contains some examples explaining how to customize those 
features.  
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• 

• 

• 

• 

• 

• 

• 

 
Add new views. You can add personal or shared views.  Remember that adding new views can increase the 
database size and consequently affect database performance. 

 
Add new forms.  For example, you can add a response document to the Contact form so users can track a 
project and have fields inherited.  To view the requests that you are tracking, you can build a new view that 
displays the projects. 

 
Add public and private folders.  Folders allow users to group documents and decide who can view them.  For 
more information about creating folders, see Lotus Notes documentation. 

 
Add action buttons to the Action Bar.  Throughout ACT! For Notes, the Action Bar contains certain buttons, 
depending on which form is displayed.  If you want, you can add buttons to the Action Bar. For example, you 
could place an action on a Company form to create an opportunity manager application. 

 
Add public or private agents to look up, automate, verify, or update contact information.  For more 
information, see Lotus Notes documentation.  

 
Build a link between ACT! For Notes documents and documents in other Lotus Notes applications. For 
example, you can fill in contact names in an opportunity manager application.  For more information about 
linking ACT! For Notes to another Lotus Notes database, see the document Customizing ACT! For Notes on 
the ACT! For Notes CD-ROM. 

 
Extract ACT! For Notes data using the @DbLookup function and use the data for lead tracking or sales 
forecasting. 

 
 

Features You Cannot Customize  
 
Although ACT! For Notes is customizable changing certain features in the design can cause problems. For best 
result, follow these guidelines:  
 
Do not add too many views. Adding too many views can affect the database and degrade ACT! For Notes 
performance.  
 
Do not modify columns where formulas exist. If you change a formula and you want to restore it, restoring the 
original formula can be difficult or impossible.  
 
Do not delete any existing ACT! For Notes forms. 
  
Do not delete any views whether hidden or not. You can tell a view is hidden if its name has parentheses around it 
in the Views Design List.  
 
Do not delete shared fields.  
 
Do not delete existing subforms, which can affect security and database performance.  
 
Do not remove default buttons on the Action Bar.  
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Chapter 6: Setting Up PDA Synchronization  
 

These guidelines will outline the process needed for synchronization to occur between ACT! For Notes Activity 
and Contact documents and the Appointment records in a standard Notes Mail file and a Notes Address Book, 
independent of what Third Party solution you have installed as long as the current conduit has the capability of 
synchronizing Notes Mail Appointments with a PDA and Contact documents in your Name and Address Book, 
then ACT! For Notes Activity and Contact documents may be synchronized by way of that functionality. 
 
 

Activity/Calendar Synchronization 
 
 
Low-Level Calendar integration provides an automatic one directional push from ACT! For Notes to the Notes 
Mail file. It requires the User to choose the Activity action button and then Pull Mail File Calendar Changes in 
order to retrieve changes to ACT! For Notes from the Notes Mail File. 
 
1. Set up Low-Level Calendar integration for each user who would like to synchronize activities in ACT! For 

Notes with their PDA, by applying the ACT! For Notes Standard Mail Template to their mail file. 
2. Create a User document for the person, ensuring to select in the Calendar Integration section, Synchronize 

Calendar with my mail file and Email Invitations to my mail file. 
 
This template adds two hidden views to the mail file ActivityID and PullMailFileCalendarChanges, to make the 
process faster and more efficient.  ACT! For Notes finds the mail file through the Location document, so ensure 
that the location document is set up properly. 
 
Any activity created in ACT! For Notes and Scheduled for the User will automatically display on the User’s mail 
file calendar.  Once synchronization with the PDA has occurred, all new activities created in the PDA and mail 
file calendar can be placed in ACT! For Notes by going to ACT! For Notes and choosing ACTIVITY > PULL 
MAIL FILE CALENDAR CHANGES.  The User will be presented with two choices: Selected Documents and 
Based on Date Criteria. 
 
By Selected documents – if the User chooses this option they will be presented with a List of all Mail file 
Appointments, where they can select which documents should be synchronized with ACT! For Notes.  
 
Based on Date Criteria – if the User chooses this option they will be presented with an input dialog to select 
documents Created before or after a certain date.  
 

Contact and Address Book Synchronization 
 
Contacts in ACT! For Notes are synchronized with the Name and  Address Book(NAB). Since ACT! For Notes is 
a collaborative application, users of ACT! For Notes can have individually defined, overlapping lists of contacts 
to synchronize with their NAB.  A simple mechanism using private folders is provided for each user to select and 
keep updated a list of contacts to synchronize. 
 
1. The Preferences document must be set up to enable PDA synchronization on a database level. 
2. The User documents must be set up individual preferences for synchronization.  The file path and name of the 

user’s personal address book must be specified here. 
  
A private on first use folder is already set up titled “My PDA Contacts”, the name of this folder cannot be 
changed.  Any contacts that the user would like synchronized to their PDA would have to be placed in this folder.  
In all of the ‘Contact’ views, there is an action under the Other action button, Place in My PDA Folder. 
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When the User selects this option, they will be presented with three options:  All Contact documents, Selected 
Documents and Based on Field Values. 
 
All Contact Documents – This action will place all contact documents in ACT! For Notes into the PDA folder. 
 
Selected Documents – This action will place any previously selected contact documents (by placing a checkmark 
next to the document(s)) into the PDA folder. 
 
Based on Field Values – There are two choices within this option.  Based on a Manager’s name or Based on a 
field value on the contact document. 
  

 Based on Manager’s Name – the User will select a Manager’s (from the Security Section) name and 
all the documents that that person is the Manager of will be placed in the PDA folder. 

 
Based on a field value – the User can set a value for any one of the following fields to be placed in the PDA 
folder 
Contact, Company, Title, Department, Phone Number, Ext, Fax, Salutation, E-Mail, ID/Status, Last Results, 
Groups, Address 1,  Address 2, Address 3, City, State, Zip Code, URL or Country. 

 
Once documents have been placed in the folder, the user will be taken automatically to the PDA folder.  They may 
also choose at any time OTHER > GO TO MY PDA FOLDER.   There are three action buttons which will assist 
with Synchronization:  Synchronize, Remove from PDA Folder and Log. 
 
Synchronize – There are two choices within this action button, All documents or Selected documents. 
 
 All Documents – this action will synchronize all documents in the PDA folder with the User’s NAB. 
 

Selected Documents – this action will synchronize only the previously selected documents (by placing a 
checkmark next to the document(s)) with the User’s NAB. 

 
Remove from PDA Folder – There are three choices available from this action:  All Contact Documents, 
Selected Documents and Based on Field Value (see description above for further information). 
 
Log – This action allows you to view information about synchronization; such as when synchronization occurred, 
how many documents were synchronized, etc.  There are three choices available from this action:  View Log, 
Trim Log and Purge Log. 
 
 View Log – Allows the user to view their entire log. 
  
 Trim Log – Allows the user to remove all but the last 10 synchronization log entries. 
 
 Purge Log – Allows the user to completely remove all synchronization log entries. 
  
 
Import from NAB 
 
 
To retrieve new contacts you have created/updated in your PDA, synchronize with the NAB, then follow the 
Import from NAB process described in Chapter 5 to create them in ACT! For Notes.  These new documents will 
be automatically added to your PDA Folder. 
 
 
Deletions from the PDA and Address Book are not sent back to ACT! For Notes.

 55



ACT! For Notes 4.1                  Administrator’s Guide 
 
 
 
 

 Chapter 7: Accessing ACT! For Notes from a Web Browser  
 

Users can access the ACT! For Notes contact database with a limited feature set from a web browser. Users’ 
Internet login name and password are specified in their person document in the Public Name & Address Book. 
The ACT! For Notes Contact database must be in your default Notes directory or in a path relative to it. The URL 
for your database will be http://[IP address of your server]/[path to database relative to default Notes directory]/.  
 

Browser Settings Recommendation  
 

Microsoft® Internet Explorer v4.x and higher Font size “Smaller” (VIEW>TEXT SIZE>SMALLER) 
when using display resolution 800x600;  

• 

• 
• 

 
Netscape® Communicator v4.x and higher 
Font size “Fixed width font” should be set to 9 when using display resolution 800x600 
 

ACL Setting Recommendations  
 

For maximum Internet security, make the Default in your ACL No Access, and create and entry called 
Anonymous with No Access (User Type Unspecified).  
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 Chapter 8: Keeping the Database Consistent  
 

ACT! For Notes provides agents to help maintain the integrity of the data. In order to use these agents, the user 
must be either listed an Editor or Designer with membership in the [AFN Admin] role, or as a Manager in the 
database ACL.  
 

Remove User Profile Agent  
 

When a user opens the contact database, a user profile document is created. The document combines user settings 
from Preferences document and current user’s User document. By “caching” the settings, “response time” is 
improved in all agents and formulas, which refer to the Preferences and User documents. These settings are easily 
accessible in the profile document. When the user closes the contact database, the User Profile document is 
removed.  
 
It is recommended to use the Remove User Profile agents if a users profile document does not get updated with 
changes from User or Preferences document.  
 
To run the Remove User Profile agent:  

 
1. Select ACTIONS>ADMIN TOOLS\REMOVE USER PROFILE from the menu.  

 
2. Select the User Profile document to remove and click OK.  

 

 
 

Check Database Consistency Agent  
 

The Check Database Consistency agent runs on all documents in the contact database. The agent checks for the 
following inconsistencies in the database:  
 
1. The document’s ID field does not match its Universal ID.  

 
2. A main document, such as a contact, has a response property. If a main document is not a replication conflict 

and a $REF field then the $REF field is removed from the document.  
 

3. A response document, such as a note or activity, does not have a corresponding parent. If a parent document 
can not found for a response document then the response document is deleted.  

 
4. A document is a response to a response document and therefore removed.  
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5. A response document has an invalid reference to a parent document. The agent compares the parent’s 
document ID, on the parent document, to the parent’s document ID, on the response document. If there is a 
difference, the agent updates the parent’s document ID on the response document. 

 
To run the Check Database Consistency agent:  

 
1. Select ACTIONS>ADMIN TOOLS>CHECK DATABASE CONSISTENCY from the menu.  
 
When the agent is finished, a dialog box displays displaying the results of the consistency check.  

 

 
 

The numbers located at the bottom right are the subtotals for the inconsistencies listed. The sum of these 
numbers should be the same as the total of the number of documents updated and deleted.  

 

Check Duplicates Agent  
 

The Check Duplicates agent scans the database for duplicate contact or user documents. Documents in which the 
contact and company name, or the user and company name match are consider duplicates. You have the option to 
delete duplicates, or put them in a folder to resolve manually.  
 
To run the Check Duplicates agent:  

 
1. Select ACTIONS>ADMIN TOOLS\CHECK DUPLICATES from the menu. The Duplicate Checking dialog 

box displays.  
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2. Select the type of documents you want to check such as Contacts or Users.  
 

3. Select how you would like to handle duplications.  
a) To place duplicates in a folder: 

Select the radio button Put in Duplicates folder and click OK.  • 
• 

• 
• 

• 

• 

• 

Duplicates are places in a folder accessible by VIEW>GO TO… A dialog box displays listing views and 
folders.  
Select Duplicates folder to view documents. You can delete the documents that you do not want.   
Select the remaining documents and click Remove from Duplicates folder action button to remove them from 
the Duplicates folder. 

 
b) To delete duplicates: 

Select the radio button Delete duplicates. Select which duplicate you would like to delete in the Selection rule 
area.  First changed deletes the document with an earlier modification date.  Last changed deletes the 
document with a later modification date. 
Select how you wish to handle the response documents connected to the deleted duplicate. Make response to 
the remaining document attaches the response documents to the document left in the database. Delete with 
main document removes the response documents from the database along with the duplicate.  
Click OK.  
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